Aqara Release Update to App With Hub Firmware Update

Aqara has released an updated version of their app (v1.4.6) that fixes a few bugs, along with some new inclusions to the list of devices you can add to the app. Alongside the update, there’s also a firmware update available, although this update is currently only available via the Aqara app, not the Mi Home app.

first off, the Aqara app now lets you add the other Mi hubs to the app. This would bring it in line with the Mi Home app in many ways, although the list of devices that can be added in the Mi Home app (if you’re connected to the Mainland China server) still outstrips Aqara’s app by a long way. Still, they have now added not only the gas and smoke sensors/alarms but also the Aqara AC companion (or Controller), a new 2-channel wireless relay controller, and a dimmer. The AC Controller doesn’t as yet get the long-awaited HomeKit support, although we’re told that this may well come in the summer of 2019. This could either mean an update to the current controller, or it could be that there may be an updated model of the controller, for HomeKit use.

The other new addition to the app itself is the provision of a new US Server option, so now you have a Mainland China server, a United State server, an ‘other region’ option, which currently does not support account login.

As regards the Aqara hub, there is now a firmware update available that brings the firmware up to v.1.5.7. Aqara were beta testing v1.5.4, so it seems that this version has been usurped with the newer update, although we have no reason why that might be at this time. In the first instance, it would seem that the firmware update requires that you bind or pair your hub to the Aqara app, but if you still prefer to update your hub without moving over to the Aqara app, there is a procedure, although we are not keen to outline it here for the following reason;

It’s quite possible that whilst all Aqara/Mi devices will still appear in the Home app, they may appear as offline in the Mi Home app, so we think it wise not to mention this method at this time.

Simon T Bramley

Editor - Musician, graphic designer and HomeKit aficionado, living in Taipei, Taiwan.

57 thoughts on “Aqara Release Update to App With Hub Firmware Update

  • 1st March 2019 at 1:49 pm
    Permalink

    Does it mena that this update will bring Mija hub and the sensor connected to it to be seen in Homekit app?

    • 1st March 2019 at 1:51 pm
      Permalink

      No, only devices that go through the Aqara Hub will be exposed to HomeKit.

  • 1st March 2019 at 2:45 pm
    Permalink

    Bonjour,

    Maintenant qu’il nous a été conseillé de migrer les Hub Aqara vers l’app Mi Home, on se retrouve coincé.

    J’ai mon premier Hub Aqara en version 1.5.0 et mon deuxième Hub Aqara que j’ai acheté récemment, est lui en version 1.4.5 et impossible de le mettre a jour vers une version plus récente 1.4.7 ou 15.0 cela est vraiment un inconvénient.

    Et je sais que de refaire passer les Hubs vers Aqara Home sera après très compliqué.

  • 2nd March 2019 at 12:01 am
    Permalink

    Hi again!

    I have 3 questions that maybe you can answer:

    1: When trying to update Aqara Hub through Aqara Home app it gets stuck at 0%. Any ideas?

    2: Do I have to register an account to download the update? I am currently not logged-in in the Aqara app but everything seems fine.

    3: Of course I have tried to register an account in the Aqara Home app but I won’t get the verification mail. Any ideas?

    4: I have alarm setup in the Mi home app, if I switch to Aqara will the alarm stop functioning? I really just want the hub updated maybe I’ll switch back to Mi later. The reason is because I want the smoke detectors in Apple Home app.

    • 2nd March 2019 at 11:22 am
      Permalink

      Hi Jocke
      I’ll see if I can address your questions one by one;
      1. You don’t need to sign into the Aqara app to update the firmware on the hub, so if you want to update, you can do so by selecting ‘other region’ in the settings for the preferred server:
      WARNING: If you do this and are already using the Mi Home app, chances are that all the devices will appear as ‘offline’ in this app, although they should appear as normal in Apple’s Home app, so if this is the case, there’s nothing I can help you with in order to get them back online in the Mi Home app. So if you want to proceed go to:

      Profile > Region > other region. From there, you can go into the settings for the Aqara hub and update it without being signed in.
      There is an update to the Mi Home app due soon that ‘may’ address the offline issue, but I don’t know this for certain.

      2. See above

      3. If you’re not getting a verification email, then double check that you’re signed in to the China Server. If you’re not, then this is probably why you aren’t getting an email. If you are signed in as described, it could be a problem if you’re using a specific domain you own – so, for example, info@jocke.se could be the issue, so using a standard Gmail or Yahoo email address, it should work.

      4. I haven’t updated the Aqara hub myself, but I have been told that the alarm in Aqara now works as it does in the Mi Home app.

      • 2nd March 2019 at 3:52 pm
        Permalink

        Thank you for the reply, much appreciated!

        If there is no advantage of refereeing I will not continue trying. Btw I have tried both my gmail and yahoo address.

        Since I got my hub I have been switching between Aqara and Mi a couple of times. Before I was prompt to bind I. The Aqara app and everything went offline in the Mi app. I then had to repair everything and I was a hassle. Dine it perhaps 3 times.
        After last update of the Aqara app i just opened it up and everything appeared as I should, although I hadn’t used the Aqara app since last reset of the hub.
        I can now switch between Aqara and Mi without issues, everything appears online and functioning.
        But I still cannot update the hub, very very disappointing.

  • Pingback:Aqara Release Update to App along with Hub Firmware Update | Active JR

  • 2nd March 2019 at 5:30 pm
    Permalink

    Hi. I’m stuck on update but finally got 1.5.7 firmware through mi Home app. After that I’ve lost control in Mi App.
    I have reset my Aqara Hub and all connected devices are still here but still not functioning. After that I’ve click buttons on every child devices and now all are functioning normally.

    • 2nd March 2019 at 6:03 pm
      Permalink

      Thanks for letting us know. Hopefully anyone else with the ‘offline’ problem will be able to get their devices working again this way.

    • 2nd March 2019 at 6:18 pm
      Permalink

      What region? Did you originally set it up in Mi Home or Aqara?
      I’m thinking I might have to reset the hub and set it up with the Aqara app, although everything is functioning normally.

      • 2nd March 2019 at 6:21 pm
        Permalink

        When I bought it – I’m set it whith Aqara app. Now I’m set it with Mi Home app.
        Region in app – Mainland China.

        • 2nd March 2019 at 6:27 pm
          Permalink

          Ok, thanks!

          I’m also set to Mainland China, have tried them all. No update in Mi, and Aqara stuck at 0%

  • 2nd March 2019 at 7:48 pm
    Permalink

    I having same issues since I update to 1.5.7 Mi Home app is offline.

  • 3rd March 2019 at 2:43 am
    Permalink

    Hello,

    I just update my hub and i can’t use my devices in Mi-Home too. They are unricheables. But all is working fine in HomeKit and Aqara Home. I will wait for the Mi Home app update’s then re connect them into it.

    Regards,

  • 3rd March 2019 at 5:21 pm
    Permalink

    Hello,
    Is someone succed to update the hub to 1.5.7 through Mi-Home?
    Is the update available in Mi-Home app?

    • 3rd March 2019 at 5:23 pm
      Permalink

      The update is only available in the Aqara app at present. You can update the hub without signing into the Aqara app, but after the update your devices will appear offline in the Mi Home app. There is an update coming soon for Mi Home that should fix this problem and also allow you to update directly within the Mi a home app, so it may be better to wait for that.

  • 5th March 2019 at 3:48 pm
    Permalink

    Mi-Home updated yesterday. i have reinstalled all my devices successfully in Mi-Home and HomeKit 🙂

    • 5th March 2019 at 4:22 pm
      Permalink

      Great. Are you running the latest firmware update for the hub? If not, it will be better to wait for the update from inside Mi Home, as they will be releasing an update for the hub soon.

  • 5th March 2019 at 4:23 pm
    Permalink

    No Aqara Hub firmware update though. My version on one Hub is 1.4.5 and according to Mi Home it is still the latest.

  • 5th March 2019 at 4:26 pm
    Permalink

    i updated mine via the Aqara app to 1.5.7. After the Mi-Home app update, all is working fine on it.

  • 5th March 2019 at 9:19 pm
    Permalink

    Hello,

    Maybe I misunderstood… Is it possible with the new version to add the AC Partner to the Aqara app?
    I can’t figure how?

    I’m new with the Aqara app and I don’t really understand how its work. For example, I can’t find the way of add actions to my switches as I do with the Mi app or Home… Is there a way?

    Thanks

    • 5th March 2019 at 10:06 pm
      Permalink

      Hi Jose
      if you’re using the AC controller in the Aqara app, then you first have to make sure you are signed in with an Aqara account. If not, then you need to create an account. Once you are signed in, you need to make sure you have the region set to Mainland China (Profile > Settings > Change Region > Mainland China). After that, return to the home screen and either click ‘add accessory’ if it appears on the home screen, or click on the ‘+’ symbol in the top left corner. From there you should see the AC Controller in the list of devices, so just follow the on-screen instructions on how to add it. Be aware that it currently does not work with HomeKit, but will hopefully be able to be added this summer.

  • 5th March 2019 at 11:39 pm
    Permalink

    Thank you!!!
    The “Other region” was the problem.

    • 6th March 2019 at 12:01 am
      Permalink

      Great. The next update to the Aqara app will bring Siri Shortcuts functionality.

  • 6th March 2019 at 1:22 am
    Permalink

    Hello, recently i update Aqara firmware from Aqara app. After that, devices appears offline at mi home app. Yesterday, i have updated mi-home app but still unavailable Aqara devices at mi-home. So, I deleted Aqara devices from mi-home. How can add again they to mi-home. Thanks.

  • 6th March 2019 at 1:49 am
    Permalink

    Finally got my hub updated by resetting it, logging in to my account in Aqara app, set region to Mainland China. After that I added the hub and it ask me to update. It’s now 1.5.7.
    Then I went to settings and linked it to Mi Home, opened Mi Home and clicked on the HomeKit menu, next to my rooms. It connected successfully and is now online and working well in Mi Home and HomeKit. My smoke detectors are now showing in HomeKit also.

  • 12th March 2019 at 12:53 am
    Permalink

    Hi,

    I updated to 1.5.7 but if I want to enable my alarm 99/100 times it disabled itself in less than a second.
    Someone have an sollution for me?

  • 13th March 2019 at 9:03 pm
    Permalink

    Well, I updated firmware in Aqara App to 1.5.9. Hoped it will fix the problem with Mi Home App. Unfortunately not.

    • 13th March 2019 at 9:07 pm
      Permalink

      Do you have a lot of devices connected to HomeKit via the Aqara Hub? If not, you can reset the hub, and re-add it to Mi Home. I’ve done it with 2 of the 3 hubs here, after updating to 1.5.9.

      • 13th March 2019 at 9:15 pm
        Permalink

        Hello,
        I’m on 1.5.7. no update available in mi-home. Do i have to wait or can i upgrade via the aqara app?
        Am i loosing connection with mi-home after ?

        Regards,

        • 13th March 2019 at 9:28 pm
          Permalink

          I can’t say for certain if you will lose connection to all your devices when binding to the Aqara app, but in theory it should be ok, but after, moving it back into the Mi Home app, you may we’ll find they appear as offline, although they might be ok on HomeKit. When I upgraded the two hubs to 1.5.9 I didn’t have any devices connected to them, so it was not an issue for me to move them to aqara and back again to Mi Home.

      • 16th March 2019 at 11:44 pm
        Permalink

        I have 29 devices and many automations. What is strange after upgrading to 1.5.7 all devices appear offline but automations (espacially those connected to wireless switches) continue to work. I am waiting for upgrade from MiHome App, but it takes too long. Maybe I will just reset the hub and set it once again from the beginning. Any information about release date?

        • 16th March 2019 at 11:55 pm
          Permalink

          I’ve not heard any more regarding the firmware update via Mi Home, but there is another firmware update via the Aqara app (1.5.9). I’ve finally updated all of my. Hubs to 1.5.9 and put them back into Mi Home, but then once again these Hub had no child devices connected, which made things easier. I’ll make an enquiry about the Mi a home update to see if there’s any progress as I know someone who was testing it.

          • 17th March 2019 at 1:25 am
            Permalink

            Will be glad if you could get back with the answer from him/her!

  • 14th March 2019 at 4:46 pm
    Permalink

    I updated my hub yesterday in 1.5.9 and everything stayed in Mi-Home ^^

  • 26th March 2019 at 5:36 pm
    Permalink

    Hello,
    After I updated my aqara hub to 1.5.9 trough My Home, the hub becomes unreachable by My Home. It’s there, under “homekit” tag, but it’s impossible to bing it to My Home. I always get the same message: “the hub fail to connect to the wifi”.

    Then I have to go back to Aqara App and bind the hub again, because, even if its failed to connect to My Home, it gets disconnected in Aqara App.

    I reset the hub to a few times (pressing 10 times the button) and I add the hub using My Home. The hub become available in Apple Home app, but still its unbindable to My Home … I have to use Aqara app to add child devices.

    From Aqara App, I trie to bring it to Mi Home, but its fail. And I so on…

    I really would like to be able to use Mi Home app instead of Aqara App, because I have more devices that aren’t compatible with Aqara, but after a few days trying everything I could, I gave up until yesterday that I got a Mi Home update that I though it could resolve the issue, but nothing have changed.

    Sorry for the long and difficult (and probability in bad English) post, but I would really appreciate any help

    • 26th March 2019 at 6:06 pm
      Permalink

      Try to add your gateway via another device if you have a tablet for example. I had the same issues with my iphone. I successfully add the gateway with my iPad. Through mi-home and HomeKit.

      • 27th March 2019 at 12:01 am
        Permalink

        Thank you!

        I can add the gateway with no problem trough Mi Home and it’s working with homekit, but them it appears as homekit device in Mi Home witch is not connected and I have to use Aqara App to add child devices.

        I read here: https://homekitnews.com/2018/12/05/aqara-hub-and-mi-home-troubleshooting-tips/

        13. in the Mi Home app, across the top, above the device tiles, there are a list of rooms. Scroll horizontally until you see a ‘HomeKit’ tab
        14. click on this and you should see your Hub. Click on it and it will go through a sort of pairing process, to complete the procedure.

        This “sort of pairing process” its what its not working: “the hub fail to connect to the wifi”. Then I go back to Aqara and I press bind.

        Anyway, I will try with my iPad tonight… fingers crossed

        • 27th March 2019 at 8:31 pm
          Permalink

          Imposible!
          No way to have the Aqara Hub connected to mi-home again.
          I guess something were wrong when I update to 1.5.9
          Thanks

          • 29th March 2019 at 7:01 am
            Permalink

            I have the same issue. All devices today became unavailable in Apple Home.
            Rebooting hub and reseting hub didn’t help.
            It’s just an error to connect. No way to pair it in Apple Home, MiHome or Aqara Home apps.

            What iOS do you have? Mine is 12.2 – the freshest, I wonder if it could be a reason of Aqara Hub failure…

    • 30th April 2019 at 9:14 pm
      Permalink

      I am having EXACTLY the same problem! It’s been driving me crazy for the las few days and I can’t find the way to fix it. Please let me know is you find the solution.

  • 29th March 2019 at 4:34 pm
    Permalink

    At last I’ve won that issue.

    When hub became “unavailable” in Apple Home app I’ve removed it in order to reconnect via MiHome.
    But I removed it as a Security System device instead of removing it as a hub.
    But Hub itself is hidden in Apple Home application and I can get it only by
    entering device card which was connected to hub, and from device card – get a hub card.

    So after restoring iPhone I’ve got “unavailable” devices again and removed hub from Apple Home
    application as a Hub, not as a Security device. Maybe that was the issue. But I didn’t face
    such kind of issues before. Maybe MiHome took part in this accident, I don’t know…
    But after restoring my iPhone MiHome app backed to 2 versions back (with old design).

    So issue is resolved but that’s a point to investigate how to avoid it in future because
    I’m not the one who faced it after that pack of updates (iOS12.2, MiHome and Hub to 1.5.9).

    • 29th March 2019 at 4:38 pm
      Permalink

      Thanks for the info Maxie, it’s something worth noting that removing one part of the device may not necessarily remove everything, although normally in HomeKit, to remove one device in a ‘two device’ product, usually removes both – for example, the iDevices Switch (actually a plug) has a night light as well as the plug. If you remove just one of these, the whole device will be removed.

    • 29th March 2019 at 6:57 pm
      Permalink

      I also have iOS 12.2 but I didn’t have any issue connecting the hub to Apple Home app… I have done it
      hundreds times in the last few days through mi-home app, but then, the hub appears as homekit device not connected and there is no way to bing it to mi-home. I have to use the Aqara app to add child devices.

  • 29th March 2019 at 5:37 pm
    Permalink

    I supposed it should be as you described, you are correct, and it used to be as you say, because I hadn’t issues regarding removing Aqara Hub as a Security system. Earlier it worked, but not in this case… So only removing an Aqara Hub as a Hub from Apple Home helped me.

    • 29th March 2019 at 5:39 pm
      Permalink

      Well if it works, that’s a good thing, and it’s best ultimately to try anything you can to get your gear to work, even if it doesn’t seem standard procedure!

  • 30th March 2019 at 8:38 am
    Permalink

    I updated my Aqara hub in Mi Home app from 1.4.7 to 1.5.9 without problem. I was afraid if it was going to fail, though. Now I have to try the smoke detector.

  • 18th April 2019 at 4:50 am
    Permalink

    Hi,

    I have got stuck with Aqara Hub. It went offline and I reset it and can not longer add to MiHome app (v .5.5.10) what is weird that I can pair to Aqara app lastest version and it works, my firmware of Aqara is 1.5.9.

    Also with Apple Home I can pair it and it works. But with MiHome it stuck all the time when at the third step – connecting to wifi.

    I think I tried everything now 🙂

    – changing ssid
    – changing dns to google once
    – trying to connect by hotspot of other device
    – reseting numerous of time
    – reseting by clicking fast 10times on reset button

    I also tried to conenct it from HomeKit app, but without success, and there is also an option from Aqara app – to move it to MiHome but after clicking it and agree on the dialog box it just move me to MiHome app without any error message or pairing proposal..

    What can be wrong actually? Maybe its last MiHome update from 11 of April? I have no IDEA.
    Support appreciated 🙂

    • 30th April 2019 at 9:27 pm
      Permalink

      New update 1.6 available through Mi-Home

  • 30th April 2019 at 10:13 pm
    Permalink

    New Mi Home app update on iOS, with new 1.6.0 firmware for the Aqara Hub.

    This update solves all my problems from the past month with the Hub (offline state in the Mi Home app and alarm system not working in HomeKit) and I hope that also solves all the problems commented in this post. \o/

  • 1st May 2019 at 11:21 pm
    Permalink

    That’s good news! Unfortunately my problem is that I can’t bind the hub to Mi Home app, so I cant update the hub (the firmware update is not showing in the Aqara app yet…I hope it’ll show up soon and it fixes the problem)

  • 12th May 2019 at 4:10 pm
    Permalink

    Hi @GDX,

    I figured it out. 1.6.1 firmware fixes the problem with pairing with MiHome app.
    You need to open Aqara app and change region to Europe (only on this region the firmware update is available).

    Update your hub to 1.6.1 and it should pair without problem.
    I was doiing it on iOS, so at first it has been added to HomeKit, but anyway it should work on Android also.

    Good luck!

    • 13th May 2019 at 2:46 am
      Permalink

      Thank you so much PafiJoe!! It worked! (changing the server to the European one did the trick, the firmware update showed up as soon as I changed it) so I can now bind the hub to the Mi Home app without a problem… but now there is another problem. Apparently, both firmwares (1.6.0 and 1.6.1) come with a bug that reduces the range of the Zigbee signal of the gateway to approx. 3 meters (it is being discussed here https://www.reddit.com/r/Aqara/comments/bn93if/child_device_not_working_with_firmware_160_nor_161/?utm_source=share&utm_medium=web2x) so, unless the sensors connected to the gateway are about 3 metres or less, they show offline or just don’t work. It looks like a lot of people are affected by this, so hopefully Aqara will release a fix soon.

      • 13th May 2019 at 3:07 am
        Permalink

        Glad to hear it helped.
        I was trying to pair Aqara Hub for weeks now, and today morning I realized that maybe its good idea to check fw updates among other regions 😉

        In regards to zigbee signal range – I have connected two subdevices today (aqara motion sensors) like 12 meters away from hub and blocked by two solid walls and there was no issues with pairing and they are still online.

        But yeah, aqara sometimes do more damage by fixing other bugs 😉

Comments are closed.